Quantcast Need Help with TSW + Flash - Basics - SecretUI
Reply
Thread Tools Display Modes
Unread 07-13-2012, 04:08 AM   #1
Orakelschaf
Join Date: Jul 2012
Posts: 6
Need Help with TSW + Flash - Basics

I played a bit with the given FLA files and the basic documentation around, but haven't digged to deep into the FLA files, yes.

I wanted to create a new ui element, not altering an existing and ran into some difficulties. I post here in hope that somebody can tell me what i did wrong

I created an emtpy FLA file, added a textarea and added some test text in the textarea. Saved it, exported it to SWF, moved the SWF to the TSW/.../flash folder, created/updated the according XML files and called the swf file in TSW.

The TSW file loaded, but the textbox only contained boxes (like missing encoding) and whenever i typed into it my typed text would not show up. Guess that is because i did not export fonts? (is this necessary with the basic ui elements within flash, or did i miss something else?)

What i noticed is that some other ui elements (f.e. the tab graphics in the friends list) get altered/moved/shifted as soon as i loaded my swf file. The tabs went back to normal after a unload + reloadui.

Can anybody help me out what i am missing and what i did wrong that both mentioned errors occur?
Orakelschaf is offline   Reply With Quote
Unread 07-16-2012, 07:31 AM   #2
Orakelschaf
Join Date: Jul 2012
Posts: 6
If i use the basic Adobe Flash CS6 Textarea the font - whatever i try (even with embedding/exporting font and altering settings for the textarea with AS) i get a broken GUI / missing fonts.

If i use the textarea from the TSW flash/custom folder everything looks fine.

Just wanted to let you know.
Orakelschaf is offline   Reply With Quote
Reply

Go BackSecretUI » Developer Discussions » Flash Help » Need Help with TSW + Flash - Basics

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off